Fixing Your Netgear Wireless Router Problems

My Netgear Wireless Router is not working properly.

I had my previous router for 3 years and had exactly ZERO problems with it, however it only supported the 802.11b wireless protocol so just didn't appear fast enough in these days of streaming video. This became a big problem when I got my X-Box 360, it was impossible to watch streamed movies. After a lot of research I decided to upgrade to a more advanced model, I went for the NetGear DG834PN Wirless ADSL Router. It boasts many features, including super g, twice normal speed with MIMO technology that eliminates dead-spots within your wireless network. Although far from the cheapest option it did appear to be the best wireless router out there, so I asked Father Christmas nicely and that's what I got.

I only had it a week when I started noticing problems, the main one being that the ADSL internet connection just drop, 2-3 times a day. The only way to fix this was to pull the power out and reset the router. This became very annoying, really quickly. As another side affect of this it would also cause the Wireless network itself to either go very slow or freeze. On occasion the PC's themselves would become totally disconnected from the router, leaving me with that annoying flashing network icon in the bottom right. This became a major issue for me as all my code is stored on a central server. After 2 hours of programming everything would just freeze, I learnt to save very often. To fix this problem I spent several weeks playing around with every setting I could find on the router, DHCP, wireless mode, broadcast, you name it I changed it and all to no avail. I gave up for a while, until by chance I came across something on the internet. Buried in an article somewhere it mentioned that NetGear routers have a very low tolerance to noise on the phone line. Every phone line has a certain amount of noise on it, dependent on what devices you have connected, the age and type of lines used etc Netgear Routers do not like this noise. I searched everywhere for a setting that would allow me to alter the tolerance level for the NetGear router but could not find it anywhere. After a lot of playing this is how I fixed the problems I was having:-

  1. Go to your favourite internet browser and type in http://192.168.0.1/setup.cgi?todo=debug in the address bar
  2. You will be prompted for your routers username and password
  3. Your browser will now say Debug Enable!

You now need to start a telnet session with your router, there are a few ways of doing this but this is what I find easiest:-

  1. Go to Start > Run
  2. Enter cmd and press OK
  3. At the command prompt that appears type telnet 192.168.0.1
  4. Your router will greet you, now we need to alter the SNR (Signal to noise ratio)
  5. Type adslctl start --snr 130
  6. Your Netgear router will now be reset and the SNR changed, the higher this number the more noise the router expects and the slower your connection will be, however it should be far more stable.
  7. Type exit twice to close the telnet session and command prompt
  8. Debug mode will timeout after a short while